Users not able to send outbound internet e-mail, but can receive ok

  • 7015523
  • 13-Aug-2014
  • 13-Aug-2014

Environment

Novell GroupWise 2012 Support Pack 2

Situation

The customer states that they can receive internet mail fine, but cannot SEND.  When any user in the
GroupWise 2012 windows client or GroupWise Webaccess client sends to any internet user 
the GroupWise 2012 windows client shows a status on the sent message of 
"transfer failed" almost immediately, and the message never hits the GWIA and MTA log errors are visible on the verbose MTA log, note the "Unable to retrieve" and "Unknown destination" errors :

11:15:40 F4A4 MTP: New receiver thread started, now 5 connections.
11:15:40 F3EA MTP: OLRGW_PO.OLRGW_DOMAIN: Accepting connection
11:15:40 F3EA MTP: OLRGW_PO.OLRGW_DOMAIN: Returning acknowledge (11)
11:15:40 F3EA MTP: OLRGW_PO.OLRGW_DOMAIN: Returning acknowledge (11)
11:15:40 F3EA MTP: OLRGW_PO.OLRGW_DOMAIN: Returning acknowledge (3)
11:15:40 F3EA MTP: OLRGW_DOMAIN: Received file: x3df6b5c.000, Size: 2272

11:15:41 F4AC RTR: OLRGW_DOMAIN: 00000836.MZ4: Routing
/groupwise/customer/mb/dom1/mslocal/gwinprog/4/00000836.MZ4 (3 kb)
11:15:41 F4AC RTR: OLRGW_DOMAIN: Unable to retrieve TCP/IP address for
novell.com
11:15:41 F4AC RTR: OLRGW_DOMAIN: 00000836.MZ4: Unknown destination: novell.com 


11:15:41 F4AC RTR: OLRGW_DOMAIN: 00000836.MZ4: Originator:
OLRGW_DOMAIN.OLRGW_PO [ofs]
11:15:41 F4AC RTR: OLRGW_DOMAIN: 00000836.MZ4: Message queued:
/groupwise/customer/mb/dom1/wpcsin/4/53df6b5d.mz!
11:15:42 F42B SCA: OLRGW_DOMAIN: Moving
/groupwise/customer/mb/dom1/wpcsin/4/53df6b5d.mz! to
/groupwise/customer/mb/dom1/mslocal/gwinprog/4/00000837.MZ4
11:15:42 F4AC RTR: OLRGW_DOMAIN: 00000837.MZ4: Routing
/groupwise/customer/mb/dom1/mslocal/gwinprog/4/00000837.MZ4 (1 kb)
11:15:42 F4AC RTR: OLRGW_DOMAIN: 00000837.MZ4 Priority 4  53DFA39A.50E:6:24894
: Transfer to OLRGW_DOMAIN.OLRGW_PO:OFS
11:15:42 F4AC RTR: OLRGW_DOMAIN: 00000837.MZ4: Message queued:
/groupwise/customer/mb/dom1/mslocal/mshold/olr85e4/4/00000837.001
11:15:42 F484 MTP: bperez4.lab.novell.com: Transmitting file
/groupwise/customer/mb/dom1/mslocal/mshold/olr85e4/4/00000837.001,
Size: 518
11:15:42 F484 MTP: Send successfully through 151.155.215.4 port 7101 
11:15:42 F484 MTP: OLRGW_PO-ipS0: Connection established.
bperez4.lab.novell.com
11:15:42 F484 MTP: bperez4.lab.novell.com: Transmitting file
/groupwise/customer/mb/dom1/mslocal/mshold/olr85e4/4/00000837.001,
Size: 518
11:15:42 F484 MTP: bperez4.lab.novell.com: End-of-file confirmation packet
received

Resolution

The actual cause for this is that System record in the GroupWise domain database was pointing to an invalid GWIA ("GWIA2") (GroupWise Internet Agent), even though that the correct "GWIA" was visibly listed in ConsoleOne, TOOLS | GroupWise System Operations | Internet Addressing, at the bottom "Internet Agent for oubound SMTP/MIME messages"
There is a user interface (UI) bug in ConsoleOne that could have introduced invalid data into the system record.  However, MTA should display a more useful informative message for trouble shooting this issue.
The new logging messages will be like this:

1994 RTR: 00001e6a.4R4: Internet mail to gw.novell.com is undeliverable because
no default GWIA is configured
Note: This issue has been fixed in GW2014 in at least build # 117045 or higher, and the fix will be ported back to a future release build of GW2012 beyond what is present in shipping GW2012 SP2 build # 108211.
NOTE: A workaround to this issue can be to set an override for the outbound gwia at a GroupWise Domain level:
1.  In ConsoleOne, highlight the GroupWise Primary domain, right click the domain, Properties, GroupWise tab, Internet addressing, check the check box for "Internet Agent for outbound SMTP/MIME messages" and select the current correct GWIA , even though it is already chosen on the list.

Cause

Invalid GroupWise System record information about the default outbound GWIA.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.