Unable to contact renderer

  • 7015506
  • 11-Aug-2014
  • 15-Apr-2015

Environment

Novell iPrint Appliance 1.1

Situation

When attempting to configure an external renderer, the following error is returned:

unable to contact renderer

At this point, the status of the renderer is: Inactive

Resolution

Apply the iPrint Appliance 1.1 Patch 1 and choose the non-secure renderer configuration.

Cause

With Novell Appliance 1.1, the communication between the Windows remote renderer and appliance is secure thru SSL using certificate authentication. For certificate authentication to work, the appliance and renderer names have to be in the same zone and the certificate must be of a certain type.  Due to the complexity of these requirements, Novell has released the ability, in the form of "iPrint-1.1.0 Field Test File 20141120", to remove these requirements. 

With the patch applied, the certificate continues to be used for web based administration tools and iPrint mobile app authentications.  The patch simple removes the certificate requirements when registering the Windows renderer.

Additional Information

If a 3rd party certificate is not being used by the Appliance and you choose not to apply the update, you can likely meet the renderer registration requirements by ensuring the DNS name of the iPrint Appliance server and Windows renderer share the same domain (zone).

Using either DNS or hosts files, configure the iPrint Appliance server and Windows Renderer machine to have resolvable names.  The names must be in the same domain (zone).
The DNS domains must match the domain listed in the Subject line of the imported certificate.  See the Additional Information section of this TID to understand that requirement. 
The following is an example of how to accommodate this requirement using hosts files:
Update the iPrint server's /etc/hosts file to have an entry for both the iPrint server and Windows renderer:
10.1.1.43     iprintserver.myorg.com
10.1.1.52     winrenderer.myorg.com
Note: In the above example, both names are in the myorg.com domain (zone).  That domain could also be something like:
10.1.1.43     iprintserver.atlanta.myorg.com
10.1.1.52     winrenderer.atlanta.myorg.com
The key is to ensure both names are in the same domain (zone).
Update the Windows renderer's hosts file with those same two entries.  To open the hosts file on a Windows a machine:
  • Run NotePad in "run as administrator" mode.
  • Choose File -> Open and browse to c:\windows\system32\drivers\etc\hosts
    • Change the "Text Documents (*.txt)" to "All Files"
    • Open the hosts file
  • Make the necessary changes
    • match the two entries in the iPrint server's hosts file
  • Save the file
You will now be able to reconfigure the Windows Renderer.

Note:
When deciding a DNS domain (zone), be sure to choose the zone which is listed in the server's certificate "Subject".  This name can be found by:
  • Go to the iPrint Appliance Management Console through a web browser
    • https://<IP or DNS>:9443
  • Choose Appliance System Configuration
  • Choose Digital Certificates
  • Highlight the imported certificate
    • Find the self-signed_cert if you did not import a 3rd party certificate:
      • Choose the drop down option next to "Key Store"
      • Choose "Web Application Certificates"
      • Highlight "self-signed_cert"
  • Click the "View Info" button.
  • Take note of the DNS domain of the server address in the Subject line. This is the DNS domain which must be used in the Resolution steps listed above.