Samsung Users get Privacy Policy prompt on ZMM app sync

  • 7015492
  • 07-Aug-2014
  • 07-Aug-2014

Environment

Novell ZENworks Mobile Management 2.9.2 App
Samsung device with KNOX

Situation

  • Samsung device with KNOX is updated to ZENworks App version 2.9.2
  • After the ZENworks App syncs, the user receives a prompt to accept a Privacy Policy
  • If the prompt is cancelled, it comes back with every ZENworks App sync
  • If the prompt is accepted, the user is prompted to set a high security password
  • The user is not given the option for locking the device even if others are allowed in the ZENworks policy suite

Resolution

  1. Update the ZENworks App on the device to at least version 2.9.3
  2. Turn off any encryption settings on the device that are not set in the assigned ZENworks policy suite

Cause

The ZENworks App version 2.9.3 sets the SD card to encrypt. This forces a high security password to be set on the device. This happens even if the ZENworks policy suite doesn't turn on encryption.