NetIQ Access Gateway Appliance 4.0 Service Pack 1 upgrade fails with error: "The appliance version 4.0.0.110 can not be upgraded"

  • 7015432
  • 28-Jul-2014
  • 28-Jul-2014

Environment

NetIQ Access Manager 4.0

Situation

  • NetIQ Access Manager 3.2.2 Access Gateway Appliance has been upgraded to 4.0 running the "upgrade.sh" script without any errors

  • running the upgrade scripts returns the error: "The appliance version 4.0.0.110 can not be upgraded to 4.0.1-88 . Refer documentation for upgrade options.' The appliance version 4.0.0.110 can not be upgraded to 4.0.1-88 . Refer documentation for upgrade options. Terminating the upgrade..."

Resolution

  • instead of running the upgrade run the steps to migrate the Access Gateway Appliance (new install).

Cause

  • The NAM 3.2.2 Access Gateway Appliance has to be migrated instead of running the upgrade. The problem is the patchlevel of the existing system is "1" instead of "3". NAM 3.2.2 is based on SLES11SP1 (patchlevel "1"). The patchlevel information is stored at: "/etc/SuSE-release" For a plain NAM 4.0 system this would be:

    SUSE Linux Enterprise Server 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 3
    NetIQ Access Manager - Access Gateway Appliance 4.0.0-110 (x86_64)

  • running the NAM 4.0 Access Gateway Appliance upgrade process should report an error instead of just running through without any further errors. This issue has been reported to engineering in order to get this check fixed for the future.

  • the NAM 4.0 upgrade process does not apply any OS service packs as required by NAM 4.0

Feedback service temporarily unavailable. For content questions or problems, please contact Support.