ZENworks Primary Server Upgrade fails with: Error occurred while importing the update into zone.

  • 7015386
  • 17-Jul-2014
  • 20-Sep-2019

Environment

Novell ZENworks Configuration Management 11
ZENworks Configuration Management 2017
ZENworks Configuration Management 2020
Microsoft Windows Server
SUSE Linux Enterprise Server
7-Zip File Archiver

Situation

  • Upgrading the first Primary server with an ISO
  • Extracted the ZENworks ISO image to the file system of the Primary server with 7-Zip (7zip) or other tool
  • The upgrade or install was run from the extracted media or
  • The zman sui command was run to import the update from the extracted media
    or
  • Install from a mounted ISO or burned CD that failed to properly mount the file system due to media "too big" to mount or burn.

If the upgrade was run from the extracted media, the following error could be seen in the ZENworks_Upgrade_<date>_<time>.log.xml:

ERROR:
Failed to import System Update. Check system update import log for more details.
Error occurred while importing the update into zone. Check the system-update-import.log in the logs directory for more details.


From system-update-import.log:

ERROR:
[SystemUpdate] [] [Unable to download content (novell-zenworks-assetmanagementmodule-langs-client-11.3.0.34994.msi) from server (file://C:\ZENworks11SP3a\Common).  Will not retry] [java.io.FileNotFoundException: Source 'C:\ZENworks11SP3a\Common\novell-zenworks-assetmanagementmodule-langs-client-11.3.0.34994.msi' does not exist

The following or similar could be seen in the system-update-import.log on a Linux primary server:

ERROR:
[SystemUpdate] [] [Unable to download content (novell-zenworks-assetmanagementmodule-langs-client-11.4.0.7532.msi) from server (file:///root/Desktop/ZENworks11SP4/Common).  Will not retry] [java.io.FileNotFoundException: Source '/root/Desktop/ZENworks11SP4/Common/novell-zenworks-assetmanagementmodule-langs-client-11.4.0.7532.msi' does not exist
...
[SystemUpdate] [] [Unable to download content from server (file:///root/Desktop/ZENworks11SP4/Common).  Will attempt alternate URLs]
...
[SystemUpdate] [] [Error downloading update] [com.novell.zenworks.systemupdate.exceptions.SystemUpdateException: Unable to download content for command (2e62382f3626b5fa12ef11b27445f44c) from any server
    at com.novell.zenworks.systemupdate.UpdateDownloader.getContentFromServer(UpdateDownloader.java:534)


If the zman sui command was run to import the system update, the following error will be seen in ZCC (ZENworks Control Center):

ERROR:
Unable to retrieve the system update from any server. Check the loader-messages.log for details.

From loader-messages.log:

ERROR:
[Loader.SystemUpdateModule] [] [FINE: Unable to download content (novell-zenworks-assetmanagementmodule-langs-client-11.3.0.34994.msi) from server (file://C:\ZENworks11SP3a\Common).  Will not retry] [java.io.FileNotFoundException: Source 'C:\ZENworks11SP3a\Common\novell-zenworks-assetmanagementmodule-langs-client-11.3.0.34994.msi' does not exist

Resolution

In either case mentioned above, do the following:
  1. Delete the extracted media from the file system of the Primary server
  2. Delete the partially imported system update if it exists:
    zman sudu -f <system-update-name>
    ex: zman sudu -f "Update for ZENworks 11 SP4"
  3. Burn the ZENworks ISO image to a DVD
    NOTE: If the DVD is too large, use a dual layer DVD and burner
  4. Run the upgrade/install or zman sui command from the mounted DVD media
Please refer to the ZENworks Server Installation Guide for more details.

Cause

It is not supported to extract the ZENworks media to the file system of the server. Please see the note on burning the ZENworks ISO image to a DVD in Installation Workflow for Your First Primary Server and Installation Workflow for Additional Primary Servers.

In one particular case, 7-Zip failed to extract at least one of the files from the media.

Status

Reported to Engineering