0x406 attempting to manage some iPrint printers

  • 7015229
  • 18-Jun-2014
  • 18-Jun-2014

Environment

Novell iPrint for Linux

Situation

When attempting to manage a printer agent using iManager, the following error is returned.

Request (CLIENT_ERROR) - bad status code (0x406)
IPP Error: 0x406


Also, users are unable to print to the printer. 

Resolution

  1. Recreate the Printer Agent with the NOSNMP switch
    • Delete the printer agent object in eDirectory
      • iManager -> iPrint -> Delete Print Object -> Browse to the problem printer agent -> Click OK
    • Recreate the Printer Agent object
      • Use the same name, same IP address, same printer driver association. 
      • For the "LPR Printer name", add NOSNMP, like this:
      • PASSTHROUGH NOSNMP
    • Access the recreated printer agent object using iManager every day for the next few days to see if the problem comes back.
      • If the problem doesn't come back, the problem is resolved.  If the problem comes back, continue with Step 2.
  2. Delete the Print Manager eDir object and recreate it.
    • Follow these steps during after hours.
    • Copy the /var/opt/novell/iprint/<print manager and ou path>.psm/padbtxt.xml to the server's /tmp directory
    • Shutdown the Print Manager
      • rcnovell-ipsmd stop
    • Rename the /var/opt/novell/iprint/<print manager and ou path>.psm directory to /var/opt/novell/iprint/<print manager and ou path>.old
    • Using ConsoleOne, delete the Print Manager object
      • You can use iManager to delete the Print Manager object, but iManager will also delete all of the iPrint printers associated to the Print Manager. If you use iCM (iPrint Client Management), all the iCM configuration will be erased during the iManager Print Manager deletion process.
    • Recreate the Print Manager object with the same attributes as the original Print Manager.
      • View the /tmp/padbtxt.xml to know which values should be used in recreating the Print Manager object:
        • Print Manager Name to populate within iManager can be found within the <dn> of the XML file
        • Container name to populate iManager can be found within the <dn> of the XML file
        • The address of the "eDir Server name" to populate iManager can be found within the <dserver> of the XML.  However, iManager will point to the ncp server object, not the network address
        • The Driver Store Name can be found within the <ids> of the XML.
        • The iPrint Service name can be found within the <hostname> of the XML.
    • Add the NOSNMP string to each printer agent which has been known to have the 0x406 error
      • Edit the /tmp/padbtxt.xml
        • add NOSNMP to each printer agent which may need the string. Example:
          • <gatewayloadstring>iprintgw PORT=LPR HOSTADDRESS=192.168.10.43 PRINTERNAME=PASSTHROUGH NOSNMP</gatewayloadstring>
    • Import the XML file (steps valid for OES11, and not valid for OES2)
      • Type the following commands at a terminal session (putty or otherwise)
        • rcnovell-ipsmd stop
        • /opt/novell/iprint/bin/ipsmd -x /tmp/padbtxt.xml -u <eDir Admin Name>
          • Replace <eDir Admin Name> with the eDirectory admin name or another eDir name which has rights to create objects.  Example format:
            • cn=admin,o=mycompany
          • Provide the eDir object password when prompted
        • Start the Print Manager after all the items are processed.
          • rcnovell-ipsmd start

Cause

Some printers send unexpectedly large amounts of SNMP data to the Print Manager. The Print Manager flags the printer agents as "corrupt" and removes those printer agents (or printer agent) from the Print Manager database file (/var/opt/novell/iprint/<print manager and OU path>.psm/psmdb.dat).  The eDirectory object for the printer agent still exists, which allows the administrator to browse to the object and select it.  However, the associated printer agent in the psmdb.dat is gone, and therefore results in the 0x406 error.