Environment
Novell GroupWise Mobility Service
Novell Data Synchronizer Mobility Pack
SUSE Linux Enterprise Server 11
Novell Data Synchronizer Mobility Pack
SUSE Linux Enterprise Server 11
Situation
Sync engine fails to start
syncengine status shows dead
webadmin status shows unused
ERROR: "Unable to contact Config Engine at https://localhost:8121/service.wsdl" in /var/log/datasync/syncengine/engine.log
ERROR: "ERROR [MainThread] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: URLError: <urlopen error [Errno 1] _ssl.c:482: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate>" in /var/log/datasync/syncengine/engine.log
syncengine status shows dead
webadmin status shows unused
ERROR: "Unable to contact Config Engine at https://localhost:8121/service.wsdl" in /var/log/datasync/syncengine/engine.log
ERROR: "ERROR [MainThread] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: URLError: <urlopen error [Errno 1] _ssl.c:482: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate>" in /var/log/datasync/syncengine/engine.log
Resolution
The date on the server is notset correctly. Please correct the time by following any of the following method.
Type the follow to force the server to sync with a time source
sntp -P no -r <time server address>
sntp -P no -r <time server address>
OR
Manually edit the time in YaST
- Launch YaST | System | Date and Time
- Select change under Date and Time
- Select Manual, and enter in correct time.
- Select Accept and OK
- Quit YaST
Once time has been corrected, restart mobility.
(1.2.x rcdatasync restart)
(2.x rcgms restart)
Cause
Mobility CA thinks it is expired when the server date is to far in the past or future.