Slow performance of Mobility server (GroupWise poll)

  • 7014487
  • 31-Jan-2014
  • 31-Jan-2014

Environment

Novell GroupWise Mobility Service 2.0
Novell Data Synchronizer Mobility Pack

Situation

Emails, appointments, contacts reach mobile devices after a long time.
Slow, delayed sync of mail or appointments - takes a long time (DataSync).
POA's with high latency (reported from WebAdmin).
Nightly Maintenance completing successfully.
TSATEST reports good disk i/o performance.

GroupWise connector reports a high queue and many instances of forcing check
(/var/log/datasync/connectors/groupwise-agent.log):
THREADPOOL: WORKERS_POOL: Queued a new task, waiting for processing = 13858
Haven't seen an event for user for 10 seconds -- forcing check.


WebAdmin Monitor reports:
Large number of retry events from devices waiting to be sent to GroupWise

Resolution

Verify the GroupWise Poll POA for Events configuration:
  1. Log in to WebAdmin (https://serverIP:8120).
  2. Select Config | GroupWise tab
  3. Verify Poll POA for Events is set to 3600 Seconds.
  4. Click Save.
  5. Restart Mobility services:
    rcgms restart

Cause

By default, the POA will "slap" Mobility when a new event occurs and Mobility will come grab it. The setting discussed above is in case it hasn't heard anything, it will go check manually. Every X number of seconds Mobility will check everyone's status for updates, querying GroupWise POA's. If this is set too low, the GroupWise Agent can be overloaded with just processing those requests to force a check.