Environment
NetIQ Identity Manager 4.0.2
NetIQ Identity Manager Driver - SalesForce.com version 4.0.0.0
NetIQ Identity Manager Driver - SalesForce.com version 4.0.0.0
Situation
Changes are not being picked up by the salesforce.com driver and populated to the identity vault.
Changes are not being processed through the publisher channel on the salesforce.com driver.
The following error is seen in the driver trace (level 3).
[01/29/14 15:16:35.835]:Salesforce Driver PT:Salesforce Driver: User is created by the salesforce login administrator,ignoring the user.
[01/29/14 15:16:35.836]:Salesforce Driver PT:Salesforce Driver: User is created by the salesforce login administrator,ignoring the user.
[01/29/14 15:16:35.836]:Salesforce Driver PT:Salesforce Driver: User is created by the salesforce login administrator,ignoring the user.
The driver is logging in as admin@myworld.com.
When logging into salesforce.com and making changes to test the driver, the user is logging in as admin@myworld.com.
Changes are not being processed through the publisher channel on the salesforce.com driver.
The following error is seen in the driver trace (level 3).
[01/29/14 15:16:35.835]:Salesforce Driver PT:Salesforce Driver: User is created by the salesforce login administrator,ignoring the user.
[01/29/14 15:16:35.836]:Salesforce Driver PT:Salesforce Driver: User is created by the salesforce login administrator,ignoring the user.
[01/29/14 15:16:35.836]:Salesforce Driver PT:Salesforce Driver: User is created by the salesforce login administrator,ignoring the user.
The driver is logging in as admin@myworld.com.
When logging into salesforce.com and making changes to test the driver, the user is logging in as admin@myworld.com.
Resolution
Create an salesforce.com administrator user to be solely used by the driver to login with.
Under the Driver Settings in the Driver Parameters section of the driver properties, Set the "Salesforce.com Login ID:" to the new administrator user created for the driver and restart the driver.
Then login to salesforce.com as a different administrator user and make a change, and see if it synchronizes.
Under the Driver Settings in the Driver Parameters section of the driver properties, Set the "Salesforce.com Login ID:" to the new administrator user created for the driver and restart the driver.
Then login to salesforce.com as a different administrator user and make a change, and see if it synchronizes.
Cause
The loopback protection of the driver is ignoring changes made in salesforce.com by the same user the driver is authenticating with to salesforce.com. Or in other words, the driver is ignoring changes made on the publisher channel by the user you have specified in "Salesforce.com Login ID:"