How to manually re-install the iPrint iManager plugin

  • 7014466
  • 28-Jan-2014
  • 29-Jan-2014

Environment

Novell iPrint for Linux Open Enterprise Server 11 Support Pack 2

Situation

When updating OES11 with Support Pack 2, which updates the iPrint Plug-in to allow printer driver management  for Windows 8.1, the "Drivers Platform" drop down list is missing Windows 8/8.1 and/or Windows 7. 

Resolution

Possible Resolution 1:  Clear the tomcat cache
Copy/paste the following command at the iPrint server terminal session (putty or otherwise):
rm -r /var/opt/novell/tomcat6/work;rcnovell-tomcat6 restart
Possible Resolution 2: Manually remove the iPrint Plug-in and re-add it.
  1. Login to iManager by going to "https://IPAddress_of_server/nps/iManager.html".
    • Select the "Configure" icon from the top of iManager.
    • Expand "Plug-in Installation".
    • Select "Installed Novell Plug-in Modules".
    • Put a check mark in front of "iPrint Linux Management Plug-in" and click "Uninstall".
    • Stop tomcat6
      • rcnovell-tomcat6 stop
  2. Once the iPrint plug-in has been uninstalled, delete the following directories (if they exist):
    • /var/opt/novell/tomcat6/work
    • /var/opt/novell/iManager/nps/portal/modules/iPrintX
    • /var/opt/novell/iManager/nps/WEB-INF/modules/iPrintX
    • Delete the following files (if they exist):
      • /var/opt/novell/iManager/nps/WEB-INF/lib/iPrintAdmin.jar
      • /var/opt/novell/iManager/nps/WEB-INF/lib/iPrintIPP.jar
      • /var/opt/novell/iManager/nps/WEB-INF/lib/iPrintLib.jar
  3. Restart tomcat
    • rcnovell-tomcat 6 restart
  4. Install the latest available plug-in
    • Go to iManager | Configure | Plug-in Installation | Available Novell Plug-in Modules
    • Log in to iManager | Configure | Plug-in Installation | Available Novell Plug-in Modules | check the box for the new iPrint Plugin
    • Click install.
    • A dialog displays indicating that the NPM has successfully installed.
      • After installing the updated plug-in, restart Tomcat
        • rcnovell-tomcat6 restart;rcapache2 restart
NOTE: If the Windows OS platforms are not available when managing the printer agent, configure RBS to accommodate the new iPrint plug-in which includes Windows 7, 8, and/or 8.1 support:
  1. Go to iManager / Configure / Role based Services / RBS configuration /  click RBS 2 object link /  Property Book tab / Manage Driver Store / Actions / Page List.
    • Note: These steps must be done for each RBS Configuration.
  2. Move the "drivers" page from "Available" to "Assigned".
  3. Similarly, go to the Manage Printer Property Book tab and move the "drivers" and "job hold" pages to "Assigned".
  4. Restart Tomcat
    • rcnovell-tomcat6 restart
  5. If iManager fails to load after the Tomcat restart (503 error), restart Apache
    • rcapache2 restart
  6. If the drivers tab is still missing at this point, then delete the tomcat work directory
    • rm -r /var/opt/novell/tomcat6/work;rcnovell-tomcat6 restart

Cause

The iManager plug-in update process sometimes retains files from the previous version of the plugin, which prevents the new Windows OS platforms from being shown.