java.lang.reflect.InvocationException attepting to login to Service Desk

  • 7014459
  • 27-Jan-2014
  • 31-Oct-2016

Environment

Novell Service Desk

Situation

Unable to login to Service Desk.
Service Desk login screen error: java.lang.reflect.InvocationException

Resolution

Fixed in Service Desk 7.1, please contact support for a workaround.

Cause

The Service Desk database table Category contains a null value.

Additional Information

Root Cause:  Category Cannot be Null Even though the category is deleted. 
 
Livetime.log
 
An error occurred when inserting the default preferences:
null
java.lang.NullPointerException
    at com.livetime.core.init.CmdbIcons.setDefault(CmdbIcons.java:33)