Username and email address do not update in GW 2012 caching mailbox after user name change

  • 7014438
  • 21-Jan-2014
  • 22-Jan-2014

Environment

Novell GroupWise 2012 Client for Windows

Situation

If a GroupWise 2012 user has an existing caching mailbox and they need to change their name and email address, the updated name and email address does not fully synchronize to the GroupWise caching mailbox.

For example, user Jane Doe has a GroupWise userID of "janedoe" and then she gets married, so the GroupWise administrator renames her GroupWise user object to "janesmith" and edits her Last name information to Jane Smith.  After the rename, when Jane Smith logs in to her caching mailbox, the information about the new name and email address will not completely propagate to her caching mailbox.

Symptoms include:
When Jane sends email from her caching mailbox to an internet user, the From: information will show "Jane Doe" <janesmith@company.com>
When you view the properties of an outbound message in Jane's "Sent Items" folder, the "Created By:" field shows the new information, but the "From:" field shows the old name of "Jane Doe"

Resolution

The problem seems to be caused by the nickname that was created during the process of renaming the user's GroupWise object.  To force the caching mailbox to fully update the Name and email address information, follow these steps:
  1. In ConsoleOne, go to the properties of that GroupWise user > GroupWise tab > Nicknames
  2. Highlight the nickname and click "Delete" and then "OK" and the new email address will sync out to the user's caching mailbox the next time that they do a Send/Retrieve in the caching client.
  3. In the user's caching client, click Accounts > Account Options > Properties and edit the "From name" field to show user's new name
  4. In the user's caching client, click Accounts > Account Options > General Options and edit the "Display name" field to show user's new name
  5. To confirm that the email address has been updated in the caching mailbox, have click Accounts > Account Options > Properties and verify that it shows the new name and email address information.

NOTE:  After deleting the nickname, the next time the GroupWise client does a Send/Retrieve the user will be prompted to enter the password for their online mailbox.  This is normal and should only happen once.

Cause

This issue has been reported to Novell Engineering.