Bundle icons not always showing in Windows start menu

  • 7014416
  • 15-Jan-2014
  • 30-May-2014

Environment

Novell ZENworks Configuration Management 11.2

Situation

  • ZCM Agent is installed on a Windows 7 device.
  • Parts of the Windows user profile including the appdata folder are redirected to a network path.
  • Device or user assigned bundles are configured to show in the Windows Start Menu
Randomly all bundle icons and related folders are missing from the Windows Start Menu.

Resolution

A fix for this issue is intended to be included in a future update to the product: however, in the interim, Novell has made a Patch available for testing, as part of an FTF Roll Up patches collection: it can be obtained at https://download.novell.com/Download?buildid=6c6917CRv6U~ as "FTF Roll Up 1 for ZENworks (11 SP3)". This update should only be applied if the symptoms above are being experienced, and are causing problems.

Please report any problems encountered when using this Patch, by using the feedback link on this TID.

Cause

NALSHELL.DLL is not always able to read and resolve path information of the user profile as required. Windows Explorer starting on user login might launch NALSHELL.DLL before a mapped used for user profile path redirection becomes available so that respective needed file access fails.