Environment
Novell ZENworks Configuration Management 11.2 Inventory
Situation
The number of inventory files uploaded to the primary servers in /var/opt/novell/zenworks/collection/inventory keeps climbing. In the loader-messages.log we see the files getting added to the queue, but none of them are processed and moved to the failure or success directory.
In ZCC > Configuration > System Updates tab, look for the section titled Available System Updates. If there is a PRU update in this section the PRU status should be Baselined. If the status is Zone Pre-Update Actions or some other status, and has been for more than a day, then this may be a cause for the inventory files not processing as they should.
In ZCC > Configuration > System Updates tab, look for the section titled Available System Updates. If there is a PRU update in this section the PRU status should be Baselined. If the status is Zone Pre-Update Actions or some other status, and has been for more than a day, then this may be a cause for the inventory files not processing as they should.
Resolution
In ZCC > Configuration > System Updates tab, look for the section
titled Available System Updates. In this section select the PRU that is stalled by clicking on the checkbox to the left of it, in the Action drop down menu select Delete Update, confirm that you want to delete the selected item by clicking on the OK button.
When the stalled PRU is deleted from the zone the inventory files should start processing again.
When the stalled PRU is deleted from the zone the inventory files should start processing again.
Cause
While the PRU is being merged into the zone the processing of inventory files is stopped so that the zone can be updated with the new product information. If a PRU merge gets stuck then the inventory files will continue to be collected and will not be processed.