Environment
Novell iPrint Appliance
Situation
Sending a png or jpg file to an iPrint printer hosted on the iPrint Appliance using AirPrint results in blank page.
Sending the same print job to an iPrint printer via email from an Exchange 2007 SP3 webmail client fails with an email auto-reply with the following message:
/var/opt/novell/log/iprintmobile/iprintmobile0.log
Sending the same print job to an iPrint printer via email from an Exchange 2007 SP3 webmail client fails with an email auto-reply with the following message:
Error occurred during document conversion.The iprintmobile0.log shows:
/var/opt/novell/log/iprintmobile/iprintmobile0.log
WARNING: Unsupported file for printing, file: /var/opt/novell/iprintmobile/jobs/<FileName>.png, Content Type: image/x-png
WARNING: Unsupported file for printing, file: /var/opt/novell/iprintmobile/jobs/<FileName>.jpg, Content Type: image/pjpeg
Resolution
Add the following two lines to the /etc/opt/novell/iprintmobile/conf/mime.types:
image/pjpeg jpgRestart the iPrint Mobile Server service.
image/x-png png
rcnovell-iprint-mobile-server restart
Cause
Both the AirPrint and Exchange webmail clients convert the image format from jpeg to pjpeg or png to x-png. pjpeg and x-png are not supported in the default iPrint Appliance mime.types. This default configuration can be changed by updating the mime.types file and restarting the iPrint Mobile Server service.