"Error: Key is not valid." Seen when Activating ZENworks Patch Management

  • 7014224
  • 05-Dec-2013
  • 05-Dec-2013

Environment

Novell ZENworks Patch Management 11 Licensing

Situation

Activating ZENworks Patch Management
Patch Management license key is verified to be valid with Novell Customer Service

The following message is seen in ZENworks Control Center - ZCC > Configuration > Product Licensing > ZENworks 11 Patch Management:

Error: Key is not valid.

The following is seen in the zcc.log:

05 Dec 2013 09:36:34 MessageUtil..........78 :Error:  Key is not valid.

The following is seen in the services-messages.log:

[DEBUG] [12/5/13 9:36:34 AM] [] [PatchLicense] [32] [] [Exception: java.lang.RuntimeException: Failed to read the license file: Failed to read the license file: ] [] []
[DEBUG] [12/5/13 9:36:34 AM] [] [PatchLicense] [32] [] [License validation complete: EXPIRED] [] []
[DEBUG] [12/5/13 9:36:34 AM] [] [PatchLicense] [32] [] [License validation complete: EXPIRED] [] []


The following file is missing from the Patch Management primary server:

Windows: %ZENWORKS_HOME%\conf\zpm.lic
Linux: /etc/opt/novell/zenworks/zpm.lic

Resolution

Correct or delete the proxy information in ZCC > Configuration > Patch Management > Configure Http Proxy
Otherwise allow traffic from the primary server to novell.patchlink.com on port 443 via local or network firewall, etc.

Cause

The Patch Management primary server is unable to reach novell.patchlink.com to download the zpm.lic file.