Environment
iManager 2.7.7.20130913
iManager server and iManager workstation
Situation
Configure rbs with iManager 2.7.7 patch 2
Remove RBS
Go to roles and tasks or View Objects. Nothing will be displayed
Force Unrestricted Access will display the roles and tasks again.
Restart tomcat does not change the results.
With previous versions when going to Configure | Role Based Services, only RBS
configuration would be seen after removing the configuration of RBS. This is
not the case, at least for the iManager server/workstation were RBS is
configured. Plugin Studio, Edit Member Association and Edit Owner Collections
is displayed, but only on iManager were RBS was configured.
iManager can be configured or deconfigured from the same iManager or configured
on one iManager and deconigured on another iManager server/workstation. The
iManger from where RBS was configured will continue to show all tasks, while
the other iManager servers or workstations will display the setting correctly.
Resolution
Edit the config.xml. For Linux this is in /var/opt/novell/iManager/nps/WEB-INF/
Removing these lines will from the config.xml appears to resolve this issue.
<setting>
<name><![CDATA[RBS.Installed.Trees.List]]></name>
<value><![CDATA[.DSF.]]></value>
</setting>
Restart iManager wtih rcnovell-tomcate7 restart and loginin again.
Another solution is to Force Unrestricted Access - TID 3739679
Cause
In the config.xml, configuring RBS adds the following (Note: DSF is the tree name and the start of the RBS scope)
<setting>
<name><![CDATA[RBS.Installed.Trees.List]]></name>
<value><![CDATA[.DSF.]]></value>
</setting>
Removing RBS should remove these lines. This is only seen on the iManager were RBS was configured.