Content satellites failing to sync content no error in ZCC

  • 7014136
  • 19-Nov-2013
  • 21-Nov-2013

Environment


Novell ZENworks Configuration Management 11.2

Situation

Although there is no error rolled up to ZCC or visible in ZENworks icon, the logs show this:

zmd-messages.log (from Satellite):

[DEBUG] [10/23/2013 19:05:00.310] [352] [ZenworksWindowsService] [37] []
[CDPSyncStateUpdater] [] [UpdateCDPSyncStateBatch called for
01774c5902d04b1d094d8efe28f6d3f9,AVAILABLE
4d44ab22571147789f8bf34a643179b1,IN_PROGRESS , result=(Code, Message): (1,
(org.hibernate.exception.ConstraintViolationException: could not execute update
query))] [] [] 

From services-messages.log on configuration primary server:

Caused by: java.sql.SQLException: Violation of UNIQUE KEY constraint
'uniq_zContentSyncState'. Cannot insert duplicate key in object
'dbo.zContentSyncState'






Resolution

Workaround:

  1. Ensure that the cdp request does not timeout by setting:  HKLM\Software\Novell\ZCM\CDPWebCallWaitTimeout registry key to prevent the timeout.
  2. Perform the following query to identify duplicates in the database:
  3. SELECT  id as 'Suspect GUID', roles as 'ROLES', count(id) as 'COUNT' from zzenserverroles where id = 0xC96147D4A5BAA1308FCE91AEEE939EAC group by roles, id having count(*) > 1
  4. Contact Technical Support for information on how to clear the duplicates.

Cause

The problem occurs after the satellite times out and tries another configuration primary to update the cdp stats.

[DEBUG] [11/15/2013 15:39:00.050] [288] [ZenworksWindowsService] [26] [] [ConnectMan] [] [   Exception causing location name https://192.168.0.33/zenworks-contentservice/ 
to be marked Bad: System.Net.WebException: The operation has timed out

Status

Reported to Engineering