ZENworks Login Suddenly Fails for all Users

  • 7013359
  • 24-Sep-2013
  • 29-Oct-2014

Environment

Novell ZENworks Configuration Management Authentication

Situation

All users see the following error when logging into ZENworks:

ERROR: Unable to log into the network because the login credentials are incorrect.

ZENworks administrators based on the ZENworks user source see the following message when logging into ZCC (ZENworks Control Center):

ERROR: An error occurred while connecting to the user source. The credentials used to access the user source are no longer valid. Please update the credentials and try again.

After logging into ZCC with the default ZENworks Administrator, the following error is seen in ZCC > Configuration > User Sources > [user source name] :

ERROR: Error:  Unable to read contexts. One or more of your connections don't support non-SSL.

Resolution

  1. Log into ZCC using the default Administrator user credentials (If these are not known, please contact Novell ZENworks Support)
  2. Verify what user is being used to connect to the user source in ZCC > Configuration > User Sources > [user source name] > General > Username and Password
  3. Fix this account in eDirectory or Active Directory if needed (clear lockout, remove password expiration policy, etc.)
  4. Enter the correct credentials in ZCC by clicking the Username and Password: Edit link
  5. Refresh any authentication satellite servers in the zone by running this command on each: zac ref bypasscache
  6. It may also be required to refresh the failing agent devices by running this command on each: zac ref bypasscache

Cause

The most common cause of this issue is that the password expires for the user configured to connect to the user source in ZCC.