Environment
NetIQ eDirectory
NetIQ iManager
Situation
Unable to user iManager to renew or repair eDirectory / LDAP certificates and/or the Root CA.
How to configure Workstation iManager on a Windows desktop for certificate administration.
Resolution
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Download the latest version of iManager to the Windows Workstation:
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From a browser, navigate to https://download.novell.com
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Select iManager and the latest version
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Click Search
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Select the link from the Download column
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Download iMan_versionNumber_workstation_win.zip
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Extract the zip to the C:\ and browse to C:\imanager\bin
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Run the iManager Windows Batch File
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(conditional) If NICI is not already installed, select Yes to do so.
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Login to iManager, providing the admin's credentials and server information.
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Install the Novell Certificate Server Plug-ins for iManager:
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Select Configure (person behind a desk icon) | Plug-in Installation | Available Novell Plug-in Modules
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From the list, select eDirectoryXX Plugins, Novell Certificate Server Plug-ins for iManager
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Click Install from the top
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Select Agree and OK
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Close out of iManager. Reload iManager from the same Windows Batch File: C:\imanager\bin\iManager
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Login to iManager. The left panel Roles & Tasks should now display the module's roles:
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Novell Certificate Access
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Novell Certificate Server
Cause
Need to use Workstation version of iManager to validate, renew, repair, re-create eDirectory certificates.
eDirectoryXX Plugin are needed to validate certificates, Novell Certificate Server Plug-ins for iManager are needed for certificate Roles & Tasks.