Unable to update Linux devices

  • 7013224
  • 09-Sep-2013
  • 28-Oct-2013

Environment

Novell ZENworks Configuration Management 11.2 System Update
Novell ZENworks Configuration Management 11.2 Content

Situation

Linux agents are applying a blank location/network environment proxy setting, preventing them from communicating with the zone. All primary servers and satellites are being marked bad since the agent has an invalid proxy configuration:

[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [ZMD] [getCurrentURI = https://<IP Address/DNS>:443/zenworks-location/] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [Fetching location configuration from URI https://<IP Address/DNS>:443/zenworks-location/] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationManager:] [ ,0] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [***************** Exception Dump ***********************] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [Exception fetching the location configuration.] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [------------------------------------------------------------------------------------] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [Message: Invalid proxy port value 0] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [Exception Type: class java.lang.IllegalArgumentException] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [Stack: com.novell.zenworks.agent.core.zmd.net.ZenProxyHostConfig.<init>(ZenProxyHostConfig.java:76)] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [------------------------------------------------------------------------------------] [] []
[Debug] [<Date>] [] [21487] [ZenworksAgent] [64] [LocationConfigurationServiceProvider] [***************** End Exception Dump ***********************] [] []

Resolution

This is fixed in version 11.2.4 - see KB 7012027 "ZENworks Configuration Management 11.2.4 - update information and list of fixes" which can be found at https://support.microfocus.com/kb/doc.php?id=7012027

Workaround:
1) Clear local cache: zac cc

2) Restart xplat agent: /etc/init.d/novell-zenworks-xplatzmd restart --clean --osgiclean

Additional Information

Checklist to assure location/proxy settings are healthy:

1) Verify if there is a proxy set for the location/network assigned to this particular device: zac sp
2) Verify '/etc/opt/novell/zenworks/zenworks.properties' to make sure there's not a proxy set up.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.