How to find a hung SOAP thread on a GroupWise POA

  • 7013102
  • 23-Aug-2013
  • 10-Dec-2013

Environment

Novell Data Synchronizer Mobility Pack

Situation

Mobility mail sync is slow. Slow sync with emails, calendar, tasks, etc.
How to find a hung or stuck SOAP thread on a GroupWise POA
Sync slow for some and/or all users
How to find a slow POA (Mobility)

Resolution

Sometimes Mobility will have a build up of events in the GroupWise connector that is caused by hung threads on a single POA. Please follow the steps below to identify a potential problem POA that is slowing down the Mobility server:

  1. At the time of writing this TID, Global Status Monitoring is a preview feature and has to be enabled.
    See documentation for Enabling the Global Status Monitor.
  2. WebAdmin | View Global Monitor | Select POAs - a list of POAs is now displayed - perhaps there is a POA with an unusually high latency identified here in this list.
  3. If a single POA has been identified from the above steps, then proceed to that POA's WebConsole (see documentation). Otherwise, check all POAs in the GroupWise Monitor list from WebAdmin.
  4. POA WebConsole | Status | SOAP Threads - a list of SOAP threads is displayed with perhaps a hung thread with state other than Idle with high Time Elapsed.
  5. Restart the POA with the stuck SOAP thread(s).
    Note: This is the only way to release the hung thread.

Cause

SOAP thread is stuck, hung, frozen preventing good performance for Mobility.