iPrint Appliance configuration results in email spam and deleted mail messages

  • 7012938
  • 24-Jul-2013
  • 25-Jul-2013

Environment

Novell iPrint Appliance

Situation

When configuring the iPrint Appliance and checking the "Enable email-based printing" option, the email address and account name/password provided experiences the following:
  • All inbox email is auto-replied to with the following subject:
    • Job Notification (Command error) (Command error)
    • The body of the email shows:
      • Failed to parse email subject line: <email subject line>
      • The rest of the email body documents proper syntax for subject lines when submiting mail messages to be printed by the iPrint Appliance.
  • All inbox mail messages are deleted.

Resolution

Workaround:
Change the email address, account user name, and account password to a newly created email account.  Email recovery techniques will need to be used to recover deleted mail messages.

Cause

The iPrint Appliance is expecting a newly created email account to be provided in this Mobile Configuration page.  With a new email address provided, existing mail messages will not exist in the inbox. See the iPrint Appliance documentation section with the title of "Email Printing".

Status

Reported to Engineering

Additional Information

You must create an exclusive email account to be used for iPrint Appliance. If you provide an existing email address (for example, your official email address), the iPrint Appliance mobile server immediately starts processing all existing emails in the inbox, replies to every mail with a response, then deletes all the received emails.

Novell is investigating a code change to:
  • More clearly warn the administrator on this Mobile Configuration page of the ramifications of entering an email address to this page.
  • Ignore older mail messages in the event the administrator erroneously enters an existing email account.