Unable to add contacts to Novell Messenger

  • 7012835
  • 11-Jul-2013
  • 11-Jul-2013

Environment

Novell Messenger

Situation

Unable to Add Contact, Search for a user - nothing is displayed in the Search Results.
Either a particular user can't add contacts, while other users are able to or nobody can add contacts.
No users able to add contacts.

Resolution

Users are considered to be part of your Messenger system if their User objects reside in a Novell eDirectory context listed in a scope profile. A default scope profile was established during installation. It's possible there are no User objects residing beneath in the context list of the default scope profile or perhaps the particular user has been assigned to another scope profile with an incorrectly defined context list. A context list can be compared to a Base DN search, where the search begins to look for users.

  1. Verify the Default Scope Profile has a correct context to begin a search and has been properly assigned:
    • Navigate to the Properties of the MessengerService object in the TREE
    • Select Novell Messenger tab | General
    • Verify there is a Default Scope Profile assigned, then select Edit on the right (pencil icon)
    • Provide a Base Search by adding a Context List Entry selecting Include sub-contexts if there is not already a valid entry.
    • If any changes were made, select Apply and then Close.

  2. Verify the user has been assigned to this Default Scope Profile
    • Navigate to the Properties of the User object in the TREE
    • Select Novell Messenger tab | General
    • If the Scope profile is left blank, it should use the Default Scope Profile assigned to the MessengerService object. However, if there is any doubt, provide the path to the Default Scope Profile, which is contained in the ScopeContainer within the MessengerService object. For example, DefaultScopeProfile.ScopeContainer.MessengerService.Servers.Novell
    • Select Apply and then Close
    • Right-click the User object | GroupWise Utilities | Synchronize and select Yes

  3. Restart Novell Messenger Agent Service:
    • From a terminal window on the Messenger server, type: rcnovell-nmma restart and press [Enter]

Cause

Improperly configured Scope Profile assigned to user or Default Scope Profile does not have a valid Context List Entry to be able to search for users in the TREE.

Additional Information