Environment
NetIQ PlateSpin Protect 10.1 +
Situation
Email notifications are not being sent when replications run.
Resolution
The easiest way to recover is to clean up WorkloadEvents table completely:
1. Pause all workloads and make sure there are no currently running jobs
2. Stop the PlateSpin Management and Operations Framework Controller services
3. Open the Microsoft SQL Server Managment Studio and connect to the PLATESPINDB instance
1. Pause all workloads and make sure there are no currently running jobs
2. Stop the PlateSpin Management and Operations Framework Controller services
3. Open the Microsoft SQL Server Managment Studio and connect to the PLATESPINDB instance
4. Expand Databases
5. Right-click on the protection database and execute the following query:
delete from WorkloadEvents
This query may take a long time to run, depending on how many events are in the table.
This query may take a long time to run, depending on how many events are in the table.
6. Run the ..\PlateSpin Protect Server\bin\RestartPlateSpinServer\RestartPlateSpinServer.exe
7. Resume all workload schedules
7. Resume all workload schedules
After the schedules are resumed, email notifications will be sent normally for future scheduled events.
Cause
When the WorkloadEvents table grows too large and is not being cleaned up as expected, there are too many events to be processed for a report to be generated. This causes the creation and sending of email notifications to fail.
Additional Information
Cleaning up the WorkloadEvents table may cause the next scheduled replication to fail to run. However, the scheduled replication after that should run as expected.