Slow sync of mail for some users

  • 7012735
  • 27-Jun-2013
  • 10-Dec-2013

Environment

Novell Data Synchronizer Mobility Pack
Novell GroupWise
Novell NetWare

Situation

Mail takes a long time to sync to Mobility for some users. Slow sync of mail.
/var/log/datasync/connectors/default.pipeline1.groupwise-AppInterface.log shows the following errors:
  • Failure parsing soap response. Response string: None; Exception: urlopen error [Errno 32] Broken pipe 
  • URLERROR: <urlopen error [Errno 32] Broken pipe>
  • GroupWise is down. Not retrying.

GroupWise POA is not sending slap event notifications for user to Mobility.
Example in groupwise-AppInterface.log:
GroupWise Event notification (slap) for user: <userID>

Resolution

Restart the user's POA.
There are times when SOAP threads are hung on some other Post Offices other than the user's Post Office. Please check all the Post Offices for hung SOAP threads and restart the POA
Update the POA to the latest version.

Cause

Hung SOAP thread(s) on POA.