Environment
Novell Data Synchronizer Mobility Pack
Situation
Unable to authenticate user from device.
No users can authenticate. Failed authentication for all users.
/var/log/datasync/connectors/default.pipeline1.mobility-AppInterface.log shows similar errors:
No users can authenticate. Failed authentication for all users.
/var/log/datasync/connectors/default.pipeline1.mobility-AppInterface.log shows similar errors:
- Failed to Authenticate user <userID>
- Authenticating to LDAP as user <userFDN>
- AUTHDATA - same wrong password
Resolution
Verify the proper address is provided in WebAdmin | Mobility Connector Settings:
- If Authentication Type is groupwise, verify GroupWise POA SOAP URL
- If Authentication Type is ldap, verify LDAP Server Address
- Make necessary changes and then restart DataSync services: rcdatasync restart
Cause
Mobility Connector set to use groupwise authentication with no GroupWise POA SOAP URL provided in Mobility Connector Settings. In this situation, the connector will attempt to authenticate the user with LDAP instead.
Additional Information
If this error still occurs, then the user is indeed providing an incorrect password. Verify the password and authentication method on the GroupWise Post Office.