Environment
Novell Data Synchronizer Mobility Pack
Situation
Can't create or edit any appointment from mobile device that contains participants
Changing the details of a multi-user appointment doesn't update the GroupWise client.
Appointment recipients are not updated with the change from the author/creator's device.
Recipients' devices are not updated with the appointment modification.
The appointment details are accurate on the author's device, but not updated anywhere else.
Errors in /var/log/datasync/connectors/default.pipeline1.mobility-AppInterface:
Exception reading users email address - {'desc': "Can't contact LDAP server"}
User is not organizer - not sending meeting request
Changing the details of a multi-user appointment doesn't update the GroupWise client.
Appointment recipients are not updated with the change from the author/creator's device.
Recipients' devices are not updated with the appointment modification.
The appointment details are accurate on the author's device, but not updated anywhere else.
Errors in /var/log/datasync/connectors/default.pipeline1.mobility-AppInterface:
Exception reading users email address - {'desc': "Can't contact LDAP server"}
User is not organizer - not sending meeting request
Resolution
- From WebAdmin | Mobility Connector Settings, provide a valid LDAP Server Address and port.
If using a secure connection, verify openLDAP is properly configured according to TID 7012481
Note: It's possible either the above field is blank in WebAdmin or the LDAP server address is not correct
(See WebAdmin | Manage Global Settings icon from the top right | LDAP Server Hostname for verification) - Once Saved, restart DataSync services with rcdatasync restart.
Cause
The Mobility Connector needs access to a valid LDAP Server to function properly.
Additional Information
Reported to Engineering.