How to rebuild the DRA Reporting database

  • 7012599
  • 13-Jun-2013
  • 22-Aug-2013

Environment

Directory and Resource Administrator 8.5.x
Directory and Resource Administrator 8.6.x
Microsoft SQL Server 2005 Management Studio
Microsoft SQL Server 2008 Management Studio
Microsoft SQL Server 2008 R2 Management Studio

Situation

The optional Directory and Resource Administrator Reporting feature utilizes a Microsoft SQL database. Each time any of the DRA Reporting Collectors run, they store the collected data in a database named DRA Reporting. This database contains all of the reporting data collected for specific Active Directory Domains managed by DRA, data about your DRA environment configuration and also summarized DRA audit data.
 
It is possible for the data in the database to become corrupted or otherwise unstable. If such a situation occurs, NetIQ Technical Support might direct the DRA Application Administrator to rebuild the DRA Reporting Database.

Resolution

Before starting on the rebuild of the DRA Reporting database it is important to create a back up of the DRA Summarized Activity data. This data is stored within the Activity Summary and Activity Count tables of the DRA Reporting DB. It is recommended to use Microsoft SQL Management Studio to either export those two tables out of the existing database, or create a duplicate copy of the existing DRA Reporting database, as a new name for backup. Once the back up has completed begin with the steps for recreating the database.
 
  • Disable DRA Reporting Services
    1. Open the Delegation and Configuration DRA Console as the AD Account running the NetIQ Administration Service
    2. Connect to the Primary DRA Server
    3. Open DRA Reporting Services Configuration
    4. Disable all of DRA Reporting
    5. Save the changes
  • Ensure that the DRA Activity Summary data from the existing DRA Reporting Database has been backed up
  • Remove the existing DRA Reporting database
    1. On the Primary DRA Server, Stop the NetIQ DRA Core Service
    2. Use MS SQL Management Studio to connect to the SQL Server hosting the DRA Reporting Database, using the AD Account configured in the DRA Reporting Database connection screen.
    3. Delete the existing DRA Reporting Database
  • Restore the DRA Reporting Configuration
    1. Open the Delegation and Configuration DRA Console as the AD Account running the NetIQ Administration Service
    2. Connect to the Primary DRA Server
    3. Open DRA Reporting Services Configuration
    4. Configure DRA Reporting SQL Server with the existing SQL Server name & instance
    5. Configure the Credentials and Admin Credentials options of the DRA Reporting SQL Server configuration
      • These are the AD Accounts used to access the database during the collector run AND used to create the database
    6. Configure the DRA Collector & AD Collector to run at a specific schedule
    7. Configure the DRA Management Reports collector to run at a specific schedule
    8. Once the configuration is complete, the new DRA Reporting database will be created on the SQL Server
  • Restore the DRA Audit Activity Summary Data
    1. Using MS SQL Management Studio import the Activity Summary and Activity Count tables data from the old DRA Reporting Database into the new DRA Reporting Database

Cause

As each DRA or AD Collector jobs runs data is changed inside the DRA Reporting database. If one or more collectors fails, or is stopped before it can fail or complete; data corruption can occur. This can cause the collector job to continue to fail due to duplicate data in the existing database.