GroupWise unable to send email or add attachments, out of free space

  • 7012420
  • 15-May-2013
  • 13-Jun-2013

Environment

Novell GroupWise 8
Novell GroupWise 2012
Novell Open Enterprise Server 2 (OES 2) Linux
Novell Open Enterprise Server 11 (OES 11) Linux

Situation

Disk space is getting low.
/var/log/ directory using up most of the space.
rewrite_log file is very very large.
GroupWise WebAccess having problems sending email or adding attachments, complaining of being out of free space.

Resolution

Edit the /etc/logrotate.d/apache2 config file, copy one of the entries there and change the log file name to be rewrite_log.

Example:
/var/log/apache2/rewrite_log {
    compress
    dateext
    maxage 365
    rotate 99
    size=+1024k
    notifempty
    missingok
    create 644 root root
    prerotate
     /etc/init.d/apache2 check-reload
    endscript
    postrotate
     /etc/init.d/apache2 reload
    endscript
}

Cause

The rewrite_log does not roll over by default, and will continue to grow indefinitely.

Additional Information

The apache process on a non OES machine, does not create this log file, nor does GroupWise WebAccess write to the file.  Only on OES is the rewrite_log active with Apache logging to that file.