Display name not showing on sent items

  • 7012402
  • 10-May-2013
  • 10-Dec-2013

Environment

RIM BlackBerry 10 device
Apple iPhone device
Novell DataSynchronizer 1.2.5.299
Novell GroupWise 2012 SP1

Situation

An item sent, from either the BlackBerry 10 or iPhone devices, looks different in the GroupWise Client Sent Items than an item sent from the client itself.
The recipient smtp address is in the To field, where the Display Name is expected to be.

Resolution

Novell DataSynchronizer development is considering for a future release, as DataSynchronizer is working as designed.

Cause

In BES 5.0.x, the BES Agent is not providing the <to> element and is being investigated by RIM.
In BlackBerry 10 though, the device has no capability of providing this field, because it’s SOAP not Active Sync, because of this Data Synchronizer needs to provide the <to> element to the POA.

Status

Reported to Engineering