Error after installation / Tomcat + Novell Service Desk does not start up

  • 7012310
  • 28-Oct-2010
  • 29-May-2013

Environment

Novell Service Desk 6.5

Situation

Error after installation / Tomcat + Novell Service Desk does not start up.

catalina.out shows:
Cannot be initialized.CUSTOMER.Novell Service Desk.URL: CUSTOMER.Novell Service Desk.URL java.lang.reflect.InvocationTargetException .... Caused by: com.webobjects.foundation.NSForwardException [java.net.UnknownHostException] CUSTOMER.Novell Service Desk.URL: CUSTOMER.Novell Service Desk.URL: initialized.: failed instantiation.

Resolution

Verify that the hosts.conf file contains the correct network configuration. Verify the network configuration for Novell Service Desk usage, check all lines to ensure that no invalid references exist for some other URL then what is being currently used for Novell Service Desk.

Cause

The cause of this turned out to be a modified hosts.conf file on RedHat Linux where the localhost line had been changed to reflect a previous network configuration. The customer had since changed the network configuration for Novell Service Desk usage but not fixed the hosts.conf to reflect this change. Have them check all lines to ensure that no invalid references exist for some other URL from what is being currently used for Novell Service Desk.

Additional Information

Formerly known as 1001196