Environment
Novell Service Desk
Situation
Once Novell Service Desk is installed, attempting to login using one of the default accounts, results in
the following error message to appear, which cannot be cleared, even
after repeated attempts to login:
Application Exception:
java.lang.IllegalArgumentException: dictionary must be non-null
Application Exception:
java.lang.IllegalArgumentException: dictionary must be non-null
Resolution
There are several solutions to this problem, all of which require knowledge of which user account is being used to run the servlet container. Once armed with this information, the choices are to:
1. Create a Novell Service Desk folder on the root of the disk, and ensure the servlet container user can write to that output location;
2. Change the output location by modifying the 'system.properties' file located within the installation, to point to a location where the user running the servlet container already has write permissions;
3. Change the output location to somewhere other than the root, and then create the Novell Service Desk folder and ensure the permissions are set correctly.
In all these cases, the core problem is based around file system permissions, rather than Novell Service Desk, and correcting them requires simple file operations as detailed above.
1. Create a Novell Service Desk folder on the root of the disk, and ensure the servlet container user can write to that output location;
2. Change the output location by modifying the 'system.properties' file located within the installation, to point to a location where the user running the servlet container already has write permissions;
3. Change the output location to somewhere other than the root, and then create the Novell Service Desk folder and ensure the permissions are set correctly.
In all these cases, the core problem is based around file system permissions, rather than Novell Service Desk, and correcting them requires simple file operations as detailed above.
Cause
This error is caused by Novell Service Desk being unable to write to
disk, in it's default output directory. On install, Novell Service Desk
attempts to create a folder called 'Novell Service Desk' on the root of
the installation disk. This is typically a permissions problem - the
user running the servlet container doesn't have enough or valid
permissions to create and/or write to the Novell Service Desk output
folder.
Additional Information
Formerly known as 1000796