Setting up Novell Service Desk Configuration Management Database (CMDB) Item Categories

  • 7012214
  • 15-Aug-2005
  • 30-May-2013

Environment

Novell Service Desk 6.5

Situation

How to set up your CMDB within Novell Service Desk > Item Categories

Resolution

Within each default Category there is much that can be configured. Please view Configuration Categories, in the link is more help along with screen shots detailing Creation as well as links to other related sections.

Cause

Within Novell Service Desk the number of Item Categories that can be defined are unlimited.

By default four System categories are seen: Hardware, Software, Service and Documentation.

Within each Item Category the Life Cycle, Classification, and Fields associated with the category can be defined. Supervisor Login > Configuration > Categories Tab

The default templates set at the Category level are used to cover a broad range of Item Types.

Additional Information

Formerly known as 10045

Configuration Categories

 

Within the application the number of Item Categories that can be defined is unlimited. By default the following Categories are included:

  • Audio Visual

  • Documentation

  • Hardware

  • Mobile Devices

  • Network Infrastructure

  • Peripherals

  • Printers & Scanners

  • Software

  • Service.

 

Within each Category the Lifecycle and Classifications associated with the Category can be defined.

 

categories.png

 

Categories Tab

The default templates set at the Category level are used to cover a broad range of Item Types. Within each default Category the following have been configured, but can be customized as required:

  • The Field Labels that will be available on the Details tab of Items using the Category

  • The broadest level of Classifications that are assigned as part of the request creation process.

  • The Lifecycle stages an Item will move through from being proposed or ordered to decommissioned

  • Template responses that Technicians can use when entering a Note for a request that is assigned an Item that uses a Category.

 

The following table illustrates how Categories can be represented as Manufacturer Models within the Configuration>Types tab:

 

    Category

    Proposed Item Type

    Hardware

    PCs, Servers, Notebooks

    Networking Infrastructure

    Routers/Switches, UPS, Cabinets, Racks

    Mobile Devices

    iPhones, PDAs, Windows MDs

    Peripherals

    Monitors, External Storage Devices, Docking Stations, Barcode Scanners

    Audio Visual

    Projectors, Electronic Whiteboards

    Printers/Scanners

    Printer, Scanner

    Digital Cameras

    Digital Still, Digital Video, Thermal Image

    Software

    Operating Systems, Databases, Applications

    Service

    Email, Website.

 

The easiest way to create additional Categories, is to duplicate a default Category and tailor it to the organizational requirements.

 

A Service Portfolio Team can be assigned to the default Service Category by creating the Team within the User>Teams screen, then selecting Edit within the Categories tab of the Service Item Category.
 

Creating a Category

  1. Select Configuration>Categories
    The Item Categories screen appears.

  2. Click New

    new_category.png

  1. Enter the name of the new Category

  2. Complete the Description
    Content entered in this field is visible when the User scrolls over the Category Name in the Item Category list.

  3. Click Save
    The Item Categories screen expands to display the options to upload an Item Category icon and customize Field labels.

  • The Item No. Validation option is displayed, if the Admin>Setup>Privileges>System> Edit Item Numbers is set to Yes
    This displays the Input Mask and User Mask fields, which are explained in the Categories Fields table below.

  1. Check the Service Category field if the template is to be used for a Service Item
    Ticking this option displays the Portfolio Team drop-down list, if Service Portfolio Teams have been created within the application. This allows Groups within the Service Portfolio Teams to be assigned to the different stages of the Item Lifecycle, and activates Service Catalog Management functionality within the Cost Tabs of Types and Items that use the template.

  • Customers cannot create Items using Item Categories that have the Service Category option enabled

    sample_category.png

  1. Select the icon to be replaced, to change the Icon image for the Item Category
    This icon is used as the generic visual representation of the Item Category in the Relationship Map. This can be refined at the Item Type level.

    category_icon.png

    Use the inline_upload.png to upload a new image or inline_cancel.png to cancel the upload.

  2. The dimensions of the uploaded icon must be exactly 32x32 or 64x64 pixels

  1. Customize the Field Labels
    Custom fields are visible in the Details tab of Items that use the Category.
    Click the Field Label link to open it in Edit mode and display the following options:

    Categories Fields

    Description

    Category

    Field Label

    The name defines what attribute information is to be recorded in the field.

    Active

    Indicates if the field will be visible in the Details tab of an Item.

    Required

    Indicates if the field is required or mandatory field.

    Customer Visible

    Defines if the Customer can see the field within the

    Customer Portal.

     

     If Yes is selected, define if the Customer can edit the field information on the Customer Portal.

    Data Type

    Dictates the field's Data Type. The options available include :

    • String - List or Free Text

    • Number

    • Boolean - radio buttons for Yes/No and True/False

    • Date - creates a date field

    • Currency- creates a currency field

    • Hyperlink.

    Style

    States the style of the field.

    eg. String- List or Free Text field. See Lists for more information on creating a list field type.

     

    Unique Value

    When active, the system prevents the duplication of data within the customized field.

    Default Value

    Value entered is the default system entry for the field, when the field is not completed manually.

    Input Validation

    When enabled the Input Mask and User Mask can be defined.

    Input Mask : A regular expression to use for data validation of values entered by a User (i.e., Zip/Post Code, telephone no.)

    User Mask: A "User Friendly" representation of the Input Mask that Customers can understand should it appear in a validation error message.

    Enable Description

    When enabled a Description field appears, allowing the User to enter details of what information is the field is expected to capture. These details are accessible next to the custom field on the relevant screen.

  2. Click Save to complete the field label configuration
    Continue to customize all fields as required.

  3. Define the ordering preference
    The option defined here dictates how the fields appear on the Item Details tab.
    To move a field, select the checkbox beside the field label followed by the inline_up.png inline_down.pngto move the label up and down the list. To multi-select fields, tick the checkboxes beside the label name and click checkmark.png  to activate or checkunmark.png  to deactivate the fields.

    The field order can be set to:

    • Alphabetical - the fields will be presented according to the alphabet order of the first letter.

    • System - the fields will appear in the order they are entered into the system.

    • User Defined - the fields can be manually adjusted by the User using the system buttons.

  4. Click Save.
    Modify the Category Lifecycle, Classifications, Responses and, if the system is synched with more than one asset management discovery tool the Federated templates, if necessary.

 

Duplicating a Category

To fast track the creation of an Item Category, each can be duplicated.

 

To duplicate an existing Category:

  1. Select Configuration>Categories

  2. Tick the box to the left of the Category name

    duplicate_category.png

  3. Click Duplicate
    A new Category hyperlink is added to the Category list. The new Category will contain the same custom fields, lifecycle and classifications of the original Item Category.

    duplicated_category.png

  4. Modify the new Category as required.

 

Editing and Configuring an Item Category Template

After an Item Category has been duplicated it can be modified to represent the new Item Category.

 

To edit a Category:

  1. Select Configuration>Categories

  2. Click on the appropriate hyperlink
    The screen defaults to the Categories>Categories tab.

  3. Click Edit

  4. Enter the name of the new Category

  5. Complete the Description
    Content entered in this field is visible when the User scrolls over the Category Name in the Item Category list.

  6. Click Save
    The Item Categories screen expands to display the options to upload an Item Category icon and customize Field labels.

  • The Item No. Validation option is displayed, if the Admin>Setup>Privileges>System> Edit Item Numbers is set to Yes. This displays the Input Mask and User Mask fields, which are explained in the Categories Fields table at Point 9.

  1. Check the Service Category field if the template is to be used for a Service Item
    Ticking this option, displays the Portfolio Team drop-down list, if Service Portfolio Teams have been created within the application. This allows Groups within the Service Portfolio Team to be assigned to the different stages of the Item Lifecycle, and activates Service Catalog Management functionality within the Cost Tabs of Types and Items that use the template.

  • Customers cannot create Items using Item Categories that have the Service Category option enabled

    sample_category.png

  1. Select the icon to be replaced, to change the icon image for the Item Category
    This icon is used as the generic visual representation of the Item Category in the Relationship Map. This can be refined at the Item Type level.

    category_icon.png

    Use the inline_upload.png to upload a new image or inline_cancel.png to cancel the upload.

  • The dimensions of the uploaded icon must be exactly 32x32 or 64x64 pixels

  1. Customize the Field Labels
    Custom fields are visible in the Details tab of Items that use the Category.
    Click the Field Label link to open it in Edit mode and display the following options:

    Categories Fields

    Description

    Category

    Field Label

    The name of the field.

    Active

    Indicates if the field is active.

    Required

    Indicates if the field is required or mandatory field.

    Customer Visible

    Defines if the Customer can see the field within the

    Customer Portal.

     

    For a Service Category, if it is relevant to display costs or other specific details  regarding a Service on  offer in the Services Tab of the Customer Portal, then set relevant attribute fields to being Customer Visible.

    Data Type

    Dictates the field's Data Type. The options available include :

    • String - List or Free Text

    • Number

    • Boolean - radio buttons for Yes/No and True/False

    • Date - creates a date field

    • Currency- creates a currency field

    • Hyperlink.

    Style

    States the style of the field.

    eg. String- List or Free Text field. See Lists for more information on creating a list field type.

     

    Unique Value

    When active, the system prevents the duplication of data within the customized field.

    Default Value

    Value entered is the default system entry for the field, when the field is not completed manually.

    Input Validation

    When enabled the Input Mask and User Mask can be defined.

    Input Mask : A regular expression to use for data validation of values entered by a User (i.e., Zip/Post Code, telephone no.)

    User Mask: A "User Friendly" representation of the Input Mask that Customers can understand should it appear in a validation error message.

    Enable Description

    When enabled a Description field appears, allowing the User to enter details of what information is the field is expected to capture. These details are accessible next to the custom field on the relevant screen.

  2. Click Save to complete the field label configuration
    Continue to customize all fields as required.

  3. Define the ordering preference
    The option defined here dictates how the fields appear on the Item Details tab.
    To move a field, select the checkbox beside the field label followed by the inline_up.png inline_down.pngto move the label up and down the list. To multi-select fields, tick the checkboxes beside the label name and click checkmark.png  to activate or checkunmark.png  to deactivate the fields.

    The field order can be set to:

    • Alphabetical - the fields will be presented according to the alphabet order of the first letter.

    • System - the fields will appear in the order they are entered into the system.

    • User Defined - the fields can be manually adjusted by the User using the system buttons.

  4. Click Save.
    Modify the Category Lifecycle, Classifications, Responses and, if the system is synched with more than one asset management discovery tool, the Federated templates, if necessary.