iManager workflows plugin administration exception

  • 7011990
  • 19-Mar-2013
  • 18-Nov-2013

Environment


NetIQ iManager
NetIQ Identity Manager
NetIQ Identity Manager Roles Based Provisioning Module

Situation

When using the iManager plugin for RBPM workflow management, the following exception occurs:

Error: Workflow - Error

The following Workflow administration exception occurred: The client stub com.novell.soa.af.impl.soap.T_Version={_Major=4,_Minor=2,_Revision=$Rev: 39235 $} doesn't match the WSDL com.novell.soa.af.impl.soap.T_Version={_Major=3,_Minor=5,_Revision=$Rev: 36967 $

Resolution

This issue happens when a RBPM patch is applied but the special instructions are not correctly followed. The manual file copy that comes after running the installer needs to be done in all iManager instances that will interact with the patched RBPM server. To fix this issue please review and follow the special instructions provided with the latest RBPM patch applied in your system.
 
The IDM plugin installed in iManager must have the exact same version number as the Roles Based Provisioning Module version . The file afadmin.jar used by iManager must match the one provided in the Roles Based Provisioning Module application server. Some RBPM patches do update that file, in that case all iManager instances, both server and workstation, need to receive the same update.

 
On iManager workstation the file usually resides at:
<iManager install directory>/tomcat/webapps/nps/WEB-INF/lib

On iManager server the file usually resides at:
<iManager install directory>/nps/WEB-INF/lib

Feedback service temporarily unavailable. For content questions or problems, please contact Support.