Deleting Devices in ZCC Results in "error performing bulk delete" "transaction log is full"

  • 7011624
  • 15-Jan-2013
  • 26-Jul-2013

Environment

Novell ZENworks Configuration Management
Microsoft SQL Server Database

Situation

Trying to delete a device in ZCC results in this error:

Error seen in ZCC:
Error:Object delete failed.: com.Novell.zenworks.datamodel.exceptions.InternalDataModelException: org.hibernate.exception.GenericJDBCException: error performing bulk delete

More specific error seen in zcc.log:

Exception occured
com.novell.zenworks.datamodel.exceptions.InternalDataModelException: com.novell.zenworks.datamodel.exceptions.InternalDataModelException: org.hibernate.exception.GenericJDBCException: error performing bulk delete
Caused by: com.novell.zenworks.datamodel.exceptions.InternalDataModelException: org.hibernate.exception.GenericJDBCException: error performing bulk delete
Caused by: org.hibernate.exception.GenericJDBCException: error performing bulk delete
Caused by: java.sql.SQLException: The transaction log for database '<database-name>' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases

Resolution

The ZENworks database needs to be backed up.

For more information about this see the Database Best Practices for Microsoft SQL Server

Cause

Note the error in bold is the "Caused by" which is the underlying error returned by the database server.