Environment
Novell ZENworks Configuration Management 11.2.1
Novell ZENworks Endpoint Security Management 11.2.1
Microsoft Windows 7
Novell ZENworks Endpoint Security Management 11.2.1
Microsoft Windows 7
Situation
Device has an additional network adapter for a mobile wireless modem
installed.
The modem can get a hardware level connection but does not get an IP address assigned.
The modem can get a hardware level connection but does not get an IP address assigned.
Resolution
This is fixed in version 11.2.2 - see KB 7010757 "ZENworks
Configuration Management 11.2.2 - update information and list of
fixes" which can be found at
https://support.microfocus.com/kb/doc.php?id=7010757
Note: this fix only applies to new agent installations, not for upgrades. See the Additional Information section for details
Note: this fix only applies to new agent installations, not for upgrades. See the Additional Information section for details
Cause
This issue is caused by a Microsoft fault in the way that Windows handles INF files, and affects how the ZESM agent component network
filter drivers get installed as required for the ZCM location detection
process.
Additional Information
The ZESM network filter driver inf files have been changed to avoid
this issue as it has been acknowledged by Microsoft to be a Windows problem.
The inf file gets only used on initial ZCM agent installation but not on updating the ZCM agent version. To get the fix applied on a device where ZCM has already been 11.2.2, the ZESM network filter driver needs to be reinstalled.
Novell development created a tool to automate filter driver reinstall which is available via a Service Request (a SR is necessary, because this tool needs to be applied with the help of Novell Technical Support).
The inf file gets only used on initial ZCM agent installation but not on updating the ZCM agent version. To get the fix applied on a device where ZCM has already been 11.2.2, the ZESM network filter driver needs to be reinstalled.
Novell development created a tool to automate filter driver reinstall which is available via a Service Request (a SR is necessary, because this tool needs to be applied with the help of Novell Technical Support).