PXE boot menu does not show after loss of communication with configuration Primary

  • 7011555
  • 21-Dec-2012
  • 21-Dec-2012

Environment

Novell ZENworks Configuration Management 11.1
Novell ZENworks Configuration Management 11.2

Situation

There are times when the imaging satellite can not talk with the parent or configuration server because of loss of  communication, so it is unable to get pre-boot policy info, and then can not show the pxeboot menu, so no imaging occur. If there is a reboot of the configuration server, once configuration server is up and responding, or if a reboot of the satellite, imaging capabilities return. 

Would like to have an imaging satellite fail over to another configuration server if the initial configuration server fails to response.

Resolution

This is fixed in version 11.2.2 - see KB 7010757 "ZENworks Configuration Management 11.2.2 - update information and list of fixes" which can be found at https://support.microfocus.com/kb/doc.php?id=7010757

Cause

When a primary ZCM server's IP, in the zenimgweb configuration, is responding to pings but is in a partial state where's it not fully functional.  The Satellite Server will fail to perform the PXE operations and either the Satellite or Primary need to be rebooted rather than the Satellite trying another Primary.

Additional Information

Once the fix is in place, On refresh, the satellite will update another primary servers IP if the current primary server entered in zenimgweb.conf is not functioning.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.