Windows eDirectory upgrade failed with an error: The specified admin user could not be logged in eDirectory.

  • 7011304
  • 02-Nov-2012
  • 09-Nov-2012

Environment

Novell eDirectory 8.8.x for Windows 2003, Windows 2008 R2

Situation

While upgrading eDirectory from 8.8 sp2 to any higher version, we get error:
"The specified Admin user could not be logged in eDirectory. The most probable cause is an incorrect password. Please verify the password, as well as the Admin context and tree name."

This error show up even when you type the correct admin password. But the same admin user is able to authenticate through Novell Client and also, can logging in eDirectory on the server locally using dsrepair.DLM.

Resolution

This error show up because the module "niciext.dlm" failed to start or it been shutdown in the Novell eDirectory Services Console in Windows.

Steps to enable niciext.dlm.
1. Go to Control panel and Click on "Novell eDirectory Services" icon.
2. From the listed dlm's, scroll to "niciext.dlm" and click on start. Make sure the niciext.dlm status show as "Running".

To make niciext.dlm start automatically, change the startup option from manual to automatic by clicking on startup button on Services tab

Cause

This error show up because the module "niciext.dlm" failed to start or it been shutdown in the Novell eDirectory Services Console in Windows.

Additional Information

Below mentioned *.dlm's are the default modules that should be in running status for Novell eDirectory to function correctly. If any one of the below is down, then please start the service manually.

dconserv.dlm
ds.dlm
dsloader.dlm
gams.dlm
httpstk.dlm
ncpengine.dlm
niciext.dlm
niciextwx64.dlm (64bit version)
nmas.dlm