Option 128 doesn't import correctly in DHCP Java Console

  • 7010963
  • 19-Oct-2012
  • 19-Oct-2012

Environment

Novell Open Enterprise Server 11 (OES 11) Linux
Novell Open Enterprise Server 2 (OES 2) Linux
DNS/DHCP Java Console

Situation

DHCP Configuration has been imported from file via DNS/DHCP Java Console
VoIP phones set to use eDirectory integrated DHCP
VoIP phones don't receive IP Address from DHCP
VoIP phones sit at 'Starting DHCP ...'

Resolution

Check the imported value for Option 128 in DHCP Console.  The import process may have stripped out part of the Option string.  Edit the option and re-input the complete value.

There is a DNS/DHCP Java Console Field Test File (FTF) available which includes a fix for the import process.

Cause

For Nortel VoIP it is required to supply Option 128 via DHCP.  This option is specified in the format:

Nortel-i2004-A,iii.iii.iii.iii:ppppp,aaa,rrr;iii.iii.iii.iii:ppppp,aaa,rrr.

Where:

Nortel-i2004-A” = Option #128 begins with this string for Nortel IP phone sets
iii.iii.iii.iii” = IP Address of the Call Server (S1 or S2)
ppppp” = Port number for the Call Server
aaa” = Action for the Server
rrr” = Retry Count for the Server

The IP Address must be separated from the port number by a colon (:). The parameters for the Primary (S1) and the Secondary (S2) Call Servers are separated by a semicolon (;). The string must end a period (.).

e.g. Nortel-i2004-A,10.1.1.10:4100,1,5;10.1.1.20:4100,1,5.

When you export the configuration from the Java DHCP Console the string appears correct in the resulting file, however because of a parsing error when it is re-imported, everything after the semicolon (;) gets stripped out.

e.g. Nortel-i2004-A,10.1.1.10:4100,1,5

Since the string must end in a period (.) the phones can no longer receive an IP Address and sit at 'Starting DHCP'.