Addressing emails not finding users from the PAB

  • 7010915
  • 11-Oct-2012
  • 11-Oct-2012

Environment

Novell GroupWise 2012
Novell GroupWise 8

Situation

  • Addressing email, user types a name, but the address lookup skips/doesn't find the desired user in the Personal Address Book (PAB) and chooses another user that's further down in the System Address Book (SAB).
  • The search order of the Address books has a PAB being above of the SAB.

Resolution

Reported to development as enhancement request.

Workaround:
For new contacts, do the following:
  • Create the contact in the PAB by entering the name to match the desired search order, so if search order is Last Name, First Name, then the Full name should be entered as the same way.
For existing contacts do ONE of the following:
  • Go into the Address Book, select view, select Name Format, highlight the books, then click "Apply to selected books".  This will go through and correct all the entries that do not match.
  • Toggle the Display name format from the one you want to the other format, apply it, then toggle back.

Cause

This is due to the way that the PAB was coded.  When users are added either as new ones, or from the SAB, the code does not automatically convert the new entries into a searchable format, it tries to search the Full Name field directly instead of the Last Name or First Name field.

Additional Information

By following the workaround, it will convert the names/contacts into the correct searchable format, and allow the PAB to correctly be searched when addressing emails.

In GroupWise Windermere (Due out Q1 of 2013), Novell hopes to change the way the PAB is indexed, searched and organized to make it more efficient and reliable.  The enhancement will be based upon time thresholds, if there is not enough time to finish this project, then it will be pushed to a future release of GroupWise.