After upgrading to SLES 11 SP2 GroupWise Agents fail on rcgrpwise stop

  • 7010901
  • 10-Oct-2012
  • 11-Jun-2013

Environment

Novell GroupWise 8 Support Pack 2 Hot Patch 3
Novell GroupWise 2012
SUSE Linux Enterprise Server 11 Service Pack 2
Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 1

Situation

  • After upgrading SLES 11 to Support Pack 2, when stopping the GroupWise agents with rcgrpwise stop, the status returned says failed.
  • When looking for .pid files in the Agents' log directories, the latest pid used was not there.
  • No core dumps can be obtained, even after enabling core dumps for GroupWise and the server.
  • Besides the shutdown status saying failed, no other symptoms occur that seem to indicate any failure.

Resolution

Development submitted a fix for GroupWise 8.0.4 and 12.0.2.  The fix will delay the shutdown, when using rcgrpwise stop, by a second to prevent the return status of fail from being reported.

1/16/2013 - The above mentioned fixes has helped some customers, but a few are still experiencing problems.  There is a workaround fix available, but it's not officially supported by development.

Cause

SLES 11 SP2 caused a timing issue in the shutdown process.  Delaying the shutdown by one second, in the grpwise script prevents this error from happening.

Additional Information

A updated version of the script can be obtained by opening up a SR and referencing this TID.  The SR will be refunded as it's a request for code.

1/16/2013 - There is a newer workaround fix available, but it's not officially supported by development.  Interested parties may contact us and ask for the script changes, so we're aware of who has the changes and can follow up with latest code as released.

Running OES 11 on SLES 11, has no bearing on the issue, it seems to be directly tied to SLES 11.  It should be noted that the problem still happens with or without OES installed on SLES 11 SP2.