Some users added by group don't show up in the connector

  • 7010846
  • 27-Sep-2012
  • 10-Dec-2013

Environment

Novell Data Synchronizer Connector for GroupWise
Novell Data Synchronizer Mobility Pack 1.2.4

Situation

Not all users show up on the GroupWise Connector.
Adding users via a Group, in Data Sync, don't all show up.
Restarting Data Sync with the group in place, doesn't help missing users show up.
Comparing the results from the command: "select count(*) from targets where "connectorID" like '%groupwise%' and disabled = '0';" and from the command: "select count(*) from "membershipCache";" show that membercache has more users then the targets entries in the Data Sync database.

Resolution

Fixes have been checked into version 1.2.5 of Data Synchronizer.

Workaround:
1)  If the membercache is higher then targets, executing: delete from "membershipCache"; will delete all the entries in the membershipCache.  Then proceed to restart Data Sync, this should then trigger all the users to get added to the GroupWise Connector.

OR

2)  Remove the group from the GroupWise Connector, restart Data Sync, then re-add the group back to the GroupWise Connector.

Avoiding the issue:
After adding a new group to any of the connectors, do NOT restart Data Sync.

Cause

Restarting Data Sync, during it's initial poll for a group, causes a interruption in adding the users and prevents Data Sync from picking up where it left off, resulting in a state where Data Sync believes all the users are added and won't try to add any others.

Additional Information

Data Sync polls groups every 30 mins for new users to be added to the connectors, restarting will also trigger this polling cycle.  However, Data Sync does not wait 30 mins when a new group is added, it immediately polls the new group.