Environment
Novell Open Enterprise Server 11 (OES 11) Linux
Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 1
Novell ZENworks Configuration Management 11.1 Bundles
Novell ZENworks Configuration Management 11.2 Bundles
Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 1
Novell ZENworks Configuration Management 11.1 Bundles
Novell ZENworks Configuration Management 11.2 Bundles
Situation
When updating an OES11 with 'zypper
up' for several package a problem is being reported. An
example is:
oes11-srv2:/etc/zypp # zypper up Open_Enterprise_Server-release
Loading repository data...
Reading installed packages...
Resolving package dependencies...
Problem: Open_Enterprise_Server-release-11-1.320.x86_64 requires Open_Enterprise_Server-release = 11-1.320, but this requirement cannot be provided
Solution 1: deinstallation of Open_Enterprise_Server-release-11-1.320.x86_64
Solution 2: do not ask to install a solvable providing Open_Enterprise_Server-release > 11-1.320
Solution 3: break Open_Enterprise_Server by ignoring some of its dependencies
Choose from above solutions by number or cancel [1/2/3/c] (c): c
oes11-srv2:/etc/zypp # zypper up Open_Enterprise_Server-release
Loading repository data...
Reading installed packages...
Resolving package dependencies...
Problem: Open_Enterprise_Server-release-11-1.320.x86_64 requires Open_Enterprise_Server-release = 11-1.320, but this requirement cannot be provided
Solution 1: deinstallation of Open_Enterprise_Server-release-11-1.320.x86_64
Solution 2: do not ask to install a solvable providing Open_Enterprise_Server-release > 11-1.320
Solution 3: break Open_Enterprise_Server by ignoring some of its dependencies
Choose from above solutions by number or cancel [1/2/3/c] (c): c
Resolution
As a work around, the file /etc/products.d/Open_Enterprise_Server.prod, can be renamed or moved to an other location. After this has been done, the update with zypper will succeed.
Cause
A YUM-repo is only containing and maintaining only package information.
Since OES is the product, the installed product info is not maintained
in the repo's primary.xml.
When the zypper command is used to perform an update and the product already exists, it will verify the corresponding file in /etc/products.d. For OES this will be /etc/products.d/Open_Enterprise_Server.prod. During the update it will check and search for associated version
binary which will not exist. This is the root cause why the update is failing.
When the zypper command is used to perform an update and the product already exists, it will verify the corresponding file in /etc/products.d. For OES this will be /etc/products.d/Open_Enterprise_Server.prod. During the update it will check and search for associated version
binary which will not exist. This is the root cause why the update is failing.