Security Vulnerability: GroupWise HTTP Interfaces Arbitrary File Retrieval Vulnerability

  • 7010772
  • 11-Sep-2012
  • 21-Sep-2012

Environment

GroupWise 8.0x up to and including 8.02HP3
GroupWise 2012

Situation

The HTTP interfaces for the GroupWise agents are vulnerable to an arbitrary file retrieval condition due to a failure to properly filter certain crafted directory traversal sequences. An unauthenticated remote attacker can leverage this flaw to retrieve files with the privileges of the vulnerable agent(s).

Resolution

To resolve this vulnerability, apply GroupWise 8.0 Support Pack 3 (or later) or GroupWise 2012 Support Pack 1.

Previous versions of GroupWise are likely also vulnerable but are no longer supported. Customers on earlier versions of GroupWise should, at a minimum, upgrade their GroupWise agents to version 8.0 Support Pack 3 or 2012 SP1 in order to secure their system.

This vulnerability was discovered and reported by the Vulnerability Research Team of Digital Defense, Inc. (http://www.ddifrontline.com), DDIVRT-2012-42"

Novell bugs 756330, 756924, CVE-2012-0419

Status

Security Alert

Feedback service temporarily unavailable. For content questions or problems, please contact Support.