Security Vulnerability - GroupWise Internet Agent (GWIA) Integer Overflow Vulnerability in HTTP interface

  • 7010769
  • 11-Sep-2012
  • 19-Sep-2012

Environment

GroupWise 8.0x up to and including 8.02HP3
GroupWise 2012

Situation

The GroupWise Internet Agent (GWIA) is vulnerable to an integer overflow exploit on its HTTP interface that could potentially allow an unauthenticated remote attacker to execute arbitrary code on vulnerable installations of GWIA.

Resolution

This vulnerability is resolved in GroupWise 8.0.3 HP1 and GroupWise 2012 Support Pack 1.
  
If you are not able to immediately update to GroupWise 8.03 HP1 or 2012 SP1, there are several options you can implement to work around the problem and secure your system: 
1. Disable the GWIA's WebConsole - preferred recommendation.
2. Block users from accessing the GWIA's WebConsole port (default 9850)

Previous versions of GroupWise are likely also vulnerable but are no longer supported. Customers on earlier versions of GroupWise should, at a minimum, upgrade their GWIA servers and associated Domains to version 8.0 Support Pack 3 or 2012 SP1 in order to secure their system.

This vulnerability was discovered and reported by Francis Provencher, Protek Research Labs via Secunia SVCRP (http://www.secunia.com/), Secunia advisory SA50622.

Novell bug 746199, CVE-2012-0271

Status

Security Alert

Bug Number

746199

Feedback service temporarily unavailable. For content questions or problems, please contact Support.