ZCM Patch Management is unable to deploy a specific patch even after recreating it

  • 7010689
  • 27-Aug-2012
  • 25-Oct-2012

Environment

Novell ZENworks Patch Management 11

Situation

When attempting to deploy a patch it will either not install and not show the association, or it will error out. This behavior is seen even though the patch bundle and definition have been deleted, re-cached, and recreated.

Scenario 1:
When deploying the patch by itself the patch does not deploy or show up as a bundle in the application explorer on the workstation.

Scenario 2:
When deploying the patch with other patches it shows up as a bundle in the application explorer but will error out with the following error:
"CachedItemError (<Bundle name containing patch here>)
There was an error that occurred during an action for bundle <Bundle name containing patch here>. Would you like to automatically verify this bundle and attempt the action again?
"

Resolution

1- In ZCC select Configuration > Patch Management > Subscription Service Information > select Reset ZENworks Patch Management Settings, then select the Yes button to continue.
2- In ZCC select Configuration > Licenses > Zenworks 11 Patch Management, enter the product activation information.
3-  In ZCC select Configuration > Patch Management > Subscription Service Information, if the service is not started select the service and start it. Then select Update Now.

Note: This process can take quite some time to finish, please be patient with it.

Warning: This will remove the currently defined mandatory baselines and they will have to be recreated.

Cause

Corruption in the patch system is the most likely cause.