Target VM cannot login to domain after test failover or failover

  • 7010614
  • 14-Aug-2012
  • 14-Aug-2012

Environment

Source workload in domain protected with Protect/Forge. Target VM remains in same domain for test failover or failover.

Situation

Test failover job completes and target boots up to Windows gina. When trying to login to domain, login fails with error "The security database on the server does not have a computer account for this workstation trust relationship". It seems like the secure channel to domain is broken.
 
Logging into target VM with a local account works just fine.

Resolution

Reconfigure workload protection and change domain joining option under test failover/failover section to the one for joining a new domain (rather than default option to keep target in same domain). Provide the same domain name and enter credentials for domain user. Run an incremental sync and then test failover job.

Cause

This is a known bug since Protect 10 and the fix was provided via the option to join a new domain.