Access denied error accessing cache folders for bundle launch

  • 7010567
  • 03-Aug-2012
  • 01-Oct-2013

Environment

Novell ZENworks Configuration Management 11.2

Situation

Access denied error accessing cache folders for bundle launch
 
ERROR (from zmd-messages.log):
 
[DEBUG] [07/30/2012 14:48:13.203] [932] [ZenworksWindowsService] [33] []
[GenericActions] [] [Got exception - System.UnauthorizedAccessException: Access
to the path 'C:\Program
Files\Novell\ZENworks\cache\zmd\ZenCache\19c5909e-1b58-4409-839b-0dbee74b3d76\someApp.exe'
is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.File.InternalCopy(String sourceFileName, String destFileName,
Boolean overwrite)
   at
Novell.Zenworks.ActionManager.GenericActions.CopyFilesLib.PerformCopy(ExistingFileData
fileData, InstallFileData installFileData, String sourceFilePath)] [] []
[ERROR] [07/30/2012 14:48:13.250] [932] [ZenworksWindowsService] [33] [user1]
[BundleManager] [GenericActions.UnexpectedError] [Unexpected error installing
file. Error: Access to the path 'C:\Program
Files\Novell\ZENworks\cache\zmd\ZenCache\19c5909e-1b58-4409-839b-0dbee74b3d76\someApp.exe'
is denied.] [] [82c9c48f32ea79a8beefac94b0136c6a]

Resolution

Workaround:
 
Run as system user or Dynamic Administrator user.  Or if the action must be run as logged in user, make a file rights policy that provides read/execute rights to Users group to %ZENWORKS_HOME%\cache and below.

Cause

The root cause for this was determined to be deleting of the entire cache folder and below in an attempt to troubleshoot a problem.  Recreation of the cache folder does not assign the same rights as those set during install.

Status

Reported to Engineering