SQL server installation requirements for Platespin Protect and Migrate

  • 7009809
  • 28-Nov-2011
  • 12-Jul-2017

Environment

PlateSpin Migrate 12.1
PlateSpin Migrate 12.2
PlateSpin Protect 11.2

Situation

In some situations it is necessary to use either a remote Microsoft SQL server or a local Microsoft SQL server that is not the Microsoft SQL Server Express installation provided with PlateSpin Migrate and Protect.

Resolution

In order for a SQL installation that is not bundled with the installer to function properly, the following settings are required:

1.  PlateSpin Protect 11.2 supports: Microsoft SQL Server 2005 Service Pack 4, MS SQL 2008 Service Pack 3,Microsoft SQL Server 2008 R2 Service Pack 2, Microsoft SQL Server 2012 Service Pack 2 and Microsoft SQL Server 2014
1a. PlateSpin Migrate 12.1and 12.2 supports: Microsoft SQL Server 2008 R2 and Microsoft SQL Server 2014
2. The SQL instance must be a Named instance (not the Default unnamed instance, which is the default installer option).
3. SQL authentication must be in mixed mode, however in order to install and use Migrate or Protect SQL authentication must be used.
4. The SQL SA user's password must be known so it can be provided during the installation of PlateSpin Migrate or PlateSpin Protect.
Note: If using another account that is not the SA account, make sure the user is a SQL user and not a Windows or Domain user and has DBO access at all times and Sysadmin access during Installation, Removal and Upgrades.
5. SQL must be set to allow both TCP/IP and Named Pipe connections.
 
If using a local Microsoft SQL instance which is installed somewhere other than C: drive, copy the contents of 
"..\Microsoft SQL Server\90\Tools" to "C:\Program Files\Microsoft SQL Server\90\Tools".

Feedback service temporarily unavailable. For content questions or problems, please contact Support.